Questions & discussions of garage door operator problems and solutions.

Latest topics

Buy Marantec Remotes

Buy Raynor Remotes

Buy Raynor Remotes

Counter


    Help Troubleshooting Linear Garage Opener

    Share

    morgantician

    Posts : 2
    Join date : 2013-11-06

    Help Troubleshooting Linear Garage Opener

    Post  morgantician on Wed Nov 06, 2013 12:08 pm

    Hello! I am in need of some help troubleshooting my Linear garage door opener (model 20030317D0152). We bought a house last spring and during inspections the door worked just fine, but after we moved in it suddenly didn't work. I didn't bother trying to fix it as summer was approaching and we didn't need the garage, but now Minnesota winter is coming.

    Here's the scenario (also of note: I am a licensed electrician and proficient with testing equipment, but inexperienced with small electronics like this, especially garage openers):

    The wall switch nor the remotes will initiate the motor. And I mean nothing - the chain doesn't move, motor doesn't try to engage, light doesn't come on. Looks as if there was no power to it at all(but I assure you there is 120v to it - first thing I checked).

    I did a continuity test of the wires going from the opener to the wall switch and both rung out clear. I have lights on on my ground sensors which correctly change when I block the beam. When I hit the wall switch absolutely nothing happens, but when I hit the remote switch the "learn" light temporarily blinks. Nothing will turn on the 120v light bulb on the opener at all (the bulb is good though, I checked).

    Some more specifics: checking voltage at the wall switch I have nothing when the switch is pressed or depressed (normal minuscule DC mv). My chain appears to be correctly on it's track and not bound up - I also turned the dial on the back of the opener to see if it moved freely and it did. When I removed the wires from the motor inside the opener I got continuity from both the red and blue leads to it's neutral wire (white) - could this indicate a grounded motor?

    I'm also wondering if there is some sort of internal fuse that may have blown that I can't find. As I said, I'm inexperienced with these things so I tried to test all my basics before I sought out help or...dare I say...call a repairman.

    Any help or direction is appreciated! Thank you!
    avatar
    GDZone
    Admin

    Posts : 225
    Join date : 2009-04-28

    Re: Help Troubleshooting Linear Garage Opener

    Post  GDZone on Thu Nov 07, 2013 3:06 pm

    It sounds like the logic board isn't functioning. It could have been damaged by lightning or a power surge. Remove the cover from the operator & take the logic board out to inspect it. Obviously if you see any burn or smoke marks then the board is cooked & needs replaced.

    morgantician

    Posts : 2
    Join date : 2013-11-06

    Re: Help Troubleshooting Linear Garage Opener

    Post  morgantician on Fri Nov 08, 2013 12:46 pm

    Thanks for your reply! I took the board out and nothing was burnt or damaged. All solder connections still looked solid and nothing looked dirty or corroded. I realize that some components can go bad without visual evidence, but was hoping I'd have definitive proof.

    Sponsored content

    Re: Help Troubleshooting Linear Garage Opener

    Post  Sponsored content


      Current date/time is Mon Dec 11, 2017 5:38 pm