Garage Door Zone

Questions & discussions of garage door operator problems and solutions.

Latest topics

Counter


    Genie IS900

    avatar
    Jox13

    Posts : 2
    Join date : 2018-09-08

    Genie IS900 Empty Genie IS900

    Post  Jox13 on Sat Sep 08, 2018 3:03 am

    I have an older Genie IS900 garage door opener. When I open or close the garage, it powers off/ dies. After a few minutes, it’ll power back on. Unplugging it and plugging it back in also fixes it temporarily. It does have Safe-T beam sensors. The green light stays lit but red flashes three times and stays solid on the 4th time.

    For the experts, could this be a sensor issue or perhaps the Genie system needs to be replaced? Any info is appreciated. Thanks!

    Jay
    Always.on.the.move19
    Always.on.the.move19

    Posts : 1
    Join date : 2019-10-31

    Genie IS900 Empty Genie IS900

    Post  Always.on.the.move19 on Thu Oct 31, 2019 12:30 pm

    Sounds like its the logic board. If it was a sensor issue it would behave differently If the op loses power during operation and then 30 secs to a couple of min it comes back on or power cycling the unit fixes the issue its the board you could try opening the power head after unplugging it and checking all the wired connections on the board.  If nothing is loose you could consider swapping the logic board but if you are going to invest upwards of $130 on a board I might suggest reaching out to your local Genie dealer and getting a quote on a model 3120H-B.  Unless you have an very heavy door over 500lb balanced weight.

      Current date/time is Wed Dec 11, 2019 4:10 pm